TiDB-Lightning Stuck at 99%

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb-lighning卡在99%

| username: peng-xin

[TiDB Usage Environment] Production Environment
[TiDB Version]
[Reproduction Path] Execute tiup tidb-lightning
[Encountered Problem: Phenomenon and Impact]
When it reaches 99%, there is no new progress for a long time.


[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page

[Attachments: Screenshots/Logs/Monitoring]

| username: TIDB-Learner | Original post link

It’s like downloading a movie to 99%. So anxious. :rofl:
What mode are you using? Did you configure checkpoint for resuming?

| username: FutureDB | Original post link

Collecting statistics using ANALYZE TABLE?

| username: Billmay表妹 | Original post link

Add your file type and import method as well: TiDB Lightning 简介 | PingCAP 文档中心

| username: dba远航 | Original post link

It might also be encountering large objects.

| username: xfworld | Original post link

How long has it been at 99%?

| username: peng-xin | Original post link

Previously, I used the logical import mode and waited for two hours without any result.
Decisively switched to the physical import mode, emptied the table and re-imported, and it was indeed super fast :grinning:

| username: peng-xin | Original post link

:grinning: Walked for more than two hours, not sure what the importer was doing. Switched to the local backend and it finished importing quickly.

| username: peng-xin | Original post link

A 10 GB SQL file is indeed quite large. Importing a few hundred megabytes is relatively fast.

| username: peng-xin | Original post link

It’s possible. I see the status of the importer is always “writing”. Can’t wait any longer, deleted and re-imported.

| username: peng-xin | Original post link

I used the SQL file exported by dumper and imported it using the TiDB backend. Changing to the local backend solved the problem.

| username: FutureDB | Original post link

I have tried the Lightning Local mode before. You can disable analyze table during the import and manually analyze the table after the data import is complete. This speeds up the process significantly.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.