TiFlash not working after upgrading to v7.5.0

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 升级到v7.5.0后tiflash用不了

| username: zengchaojie

Error when using TiFlash

Executes normally without TiFlash

| username: FutureDB | Original post link

You can first check if the TiFlash replica is available

select * from information_schema.tiflash_replica where table_name='xxx'
| username: Jellybean | Original post link

Try changing tidb_isolation_read_engines=“tiflash” to “tiflash,tidb” and see if that works.

| username: ShawnYan | Original post link

Check the number of TiFlash replicas,
and capture the TiFlash logs when executing the error statement.

| username: Kongdom | Original post link

From which version did you upgrade to v7.5.0?

| username: zengchaojie | Original post link

It can be used.

| username: zengchaojie | Original post link

It is also not allowed.

| username: zengchaojie | Original post link

Upgraded from 7.1.2, I had no issues after upgrading on the test server as well.

| username: 路在何chu | Original post link

Try expanding it again and see.

| username: 路在何chu | Original post link

Get rid of the existing one.

| username: zengchaojie | Original post link

This might work to recover, but it is equivalent to rebuilding and will take a long time.

| username: zengchaojie | Original post link

Do I have to enable the tidb_allow_mpp parameter for version 7.5.0? I mentioned that the test environment was also upgraded to 7.5.0, and it worked because this parameter was enabled.

| username: zengchaojie | Original post link

This is the issue I encountered in version 7.1.2
使用tiflash查询结果为空 - #10,来自 windtalker - TiDB 的问答社区.

| username: Kongdom | Original post link

It doesn’t seem to say that it must be enabled. :thinking:

| username: Kongdom | Original post link

You can enable verification and give it a try.

| username: zengchaojie | Original post link

Enabling it does work, but disabling it doesn’t.

| username: Kongdom | Original post link

:thinking: That is probably a bug. You can report it in the suggestions and feedback section.

| username: 江湖故人 | Original post link

This is not a bug, right? I understand that to use TiFlash, you need to enable MPP mode.

| username: zengchaojie | Original post link

I didn’t need to enable it in version 5.4.2 before, I always kept it closed and used it normally.

| username: 江湖故人 | Original post link

This is the issue I encountered in version 7.1.2
Query result using TiFlash is empty - #10 by windtalker.

Who gets the blame for encountering such a bug in a production environment? :face_with_open_eyes_and_hand_over_mouth: