TiKV is responding very slowly

This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tikv响应很慢

| username: 月明星稀

TiKV is responding slowly and reporting this error. Could someone help me understand what the issue is and whether it will affect TiKV’s response?

| username: Billmay表妹 | Original post link

What version?
What is the configuration?
Did you perform any operations?

| username: Fly-bird | Original post link

Data lost?

| username: 月明星稀 | Original post link

Version: 6.5.0

WARNING: This file is auto-generated. Do not edit! All your modifications will be overwritten!

You can use ‘tiup cluster edit-config’ and ‘tiup cluster reload’ to update the configuration

All configuration items you want to change can be added to:



aa.b1.c3: value

aa.b2.c4: value

ca-path = “/usr/local/xxxx/tikv-22222/tls/ca.crt”
cert-allowed-cn = [“xx.xx”, “xx.xx”]
cert-path = “/usr/local/xxxx/tikv-22222/tls/tikv.crt”
key-path = “/usr/local/xxxx/tikv-22222/tls/tikv.pem”

api-version = 2
enable-ttl = true

No operations were performed, but after running for a while, the response became slow.

| username: 像风一样的男子 | Original post link

Use pd-ctl to check the status of region 5005.

| username: zhanggame1 | Original post link

INFO level can be ignored, it is not considered an error.

| username: 月明星稀 | Original post link

What does this indicate? Will it affect response time?

| username: tidb菜鸟一只 | Original post link

The response time is slow, check the TiKV-related monitoring on Grafana.

| username: ajin0514 | Original post link

It seems that data has been lost.

| username: 大飞哥online | Original post link

At the slow time point, monitor the data.

| username: 有猫万事足 | Original post link

Region misses should not be too common. I had disabled region miss alerts for a while back then. At that time, to prevent write hotspots, I pre-split many regions. It is possible that I split the regions too finely, and since the import hadn’t started, these empty regions were frequently scheduled.