TikvReaderGUI Developed Based on JavaFX

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 基于javaFX 开发 的TikvReaderGUI

| username: 表渣渣渣

【TiDB Usage Environment】Testing
【TiDB Version】
【Reproduction Path】TIPD connection exception across different subnets
【Encountered Problem: Phenomenon and Impact】
I wrote a GUI using TIKVClient to connect to TiKV and read data, but there is still one issue that I haven’t figured out.

Connection test: When connecting within the same subnet, there is no problem. However, when connecting across different subnets, it fails to connect and does not report an error, only timing out after a certain period. I hope the developers can explain this to me.

Here are the code repositories:

Of course, I hope this tool can help everyone :laughing:

| username: xfworld | Original post link

Not bad, thanks for sharing~


Network issues need to be logged and troubleshooted, which are largely related to the environment…

| username: 大飞哥online | Original post link

Great, thumbs up!

| username: ti-tiger | Original post link

Whether it can be pinged or not

| username: ajin0514 | Original post link

Try pinging it.

| username: 表渣渣渣 | Original post link

All ports are reachable via ping. I had the operations team check, and there is no data coming through on the TiKV 20160 port.

| username: 表渣渣渣 | Original post link

I haven’t done operations and maintenance, and I’m not very familiar with networking, so I’m relatively weak in this area.

| username: ti-tiger | Original post link

So is it a firewall issue? Have you tried using telnet?

| username: cassblanca | Original post link

tracert -d ip x.x.x.x Check for yourself where it is not connected.

| username: 表渣渣渣 | Original post link

I have tried it, and it works.

| username: 表渣渣渣 | Original post link

I’ll give this a try.

| username: 表渣渣渣 | Original post link

C:\Users\1180>tracert -d 10.200.xx.xx

Tracing route to 10.200.xx.xx over a maximum of 30 hops

1 * * * Request timed out.
2 * * * Request timed out.
3 <1 ms <1 ms <1 ms 192.168.200.254
4 * * * Request timed out.
5 8 ms 9 ms 8 ms 10.200.xx.xx

| username: cassblanca | Original post link

This clearly indicates that the intermediate node network is not connected. Just ask the network administrator to adjust the policy.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.