TiUP 1.14 Deployment Failed

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tiup 1.14 部署失败

| username: TiDBer_NIpp5a2i

[TiDB Usage Environment] Production Environment
[TiDB Version] 7.5
[Reproduction Path] Install tiup, configure topology.yaml, execute deployment command tiup cluster deploy tidb v7.5.0 ./topology.yaml --user root
topology.yaml:

# Global variables are applied to all deployments and used as the default value of

# the deployments if a specific deployment value is missing.

global:
user: “tidb”
ssh_port: 22
deploy_dir: “/data/tidb-deploy”
data_dir: “/data/tidb-data”

server_configs:
tikv:
readpool.unified.max-thread-count:
readpool.storage.use-unified-pool: false
readpool.coprocessor.use-unified-pool: true
storage.block-cache.capacity: “”
raftstore.capacity: “”
pd:
replication.location-labels: [“host”]

pd_servers:

  • host: 192.168.30.210

tidb_servers:

  • host: 192.168.30.210
    port: 3306
    status_port: 10081
    numa_node: “0”

tikv_servers:

  • host: 192.168.30.210
    port: 20161
    status_port: 20181
    numa_node: “0”
    config:
    server.labels: { host: “192.168.30.210”}
  • host: 192.168.30.210
    port: 20162
    status_port: 20182
    numa_node: “1”
    config:
    server.labels: { host: “192.168.30.210”}

tiflash_servers:

  • host: 192.168.30.210
    data_dir: /data/tidb-data/tiflash-9000
    deploy_dir: /data/tidb-deploy/tiflash-9000

monitoring_servers:

  • host: 192.168.30.210

grafana_servers:

  • host: 192.168.30.210

alertmanager_servers:

  • host: 192.168.30.210
    web_port: 19093
    cluster_port: 19094

[Resource Configuration] Installation not successful

| username: TiDBer_NIpp5a2i | Original post link

Is there any expert who can help check if there is an issue with the deployment script?

| username: WalterWj | Original post link

Either configure it or delete it, don’t leave it empty.

| username: TiDBer_NIpp5a2i | Original post link

I’ll give it a try, thanks.

| username: WalterWj | Original post link

Why is this not configured… Don’t just write the configuration without specifying the value.

| username: 连连看db | Original post link

The issue is with TiKV. You can see there’s an additional config. Either adjust the configuration parameters or remove it.

| username: wangccsy | Original post link

Cannot SSH to another host, right?

| username: TiDBer_小阿飞 | Original post link

Check this against the documentation again.

| username: zhanggame1 | Original post link

It’s not a parameter issue, don’t look at the configuration file. It’s just that SSH can’t connect, and the most common problem is an incorrect password.

| username: andone | Original post link

Configure SSH passwordless login and turn off the firewall.

| username: Jellybean | Original post link

The error reason “invalid auto generate configuration file” indicates that the TiKV-related configuration parameters cannot be correctly extracted, and there is an issue related to the file format.

server_configs:
tikv:
readpool.unified.max-thread-count:
readpool.storage.use-unified-pool: false
readpool.coprocessor.use-unified-pool: true
storage.block-cache.capacity: ""
raftstore.capacity: ""

Several items in the above configuration are empty, which might be problematic. Try changing it to the following content:

server_configs:
tikv:
readpool.storage.use-unified-pool: false
readpool.coprocessor.use-unified-pool: true
| username: tidb菜鸟一只 | Original post link

Delete these two for now.

| username: Kongdom | Original post link

These two are values with units. If not needed, you can delete them.

storage.block-cache

Configuration option for sharing block cache among multiple CFs in RocksDB.

capacity

  • The size of the shared block cache.
  • Default value:
    • When storage.engine="raft-kv", the default value is 45% of the total system memory.
    • When storage.engine="partitioned-raft-kv", the default value is 30% of the total system memory.
  • Units: KB|MB|GB

capacity

  • Storage capacity, i.e., the maximum allowed data storage size. If not set, the current disk capacity is used. If you want to deploy multiple TiKV instances on the same physical disk, you need to add this parameter in the TiKV configuration. Refer to Key Parameters for Hybrid Deployment.
  • Default value: 0
  • Units: KB|MB|GB
| username: xfworld | Original post link

TiKV should either be a single node or three nodes, preferably an odd number, otherwise it won’t start… :rofl:

| username: TiDBer_小阿飞 | Original post link

Is it because a leader couldn’t be elected? Haha.

| username: xfworld | Original post link

The requirement for a Raft majority… cannot be met…

| username: Kongdom | Original post link

TiKV does not have leader election; PD is responsible for leader election. :yum:

| username: dba远航 | Original post link

It feels like a configuration item value is missing.