TiUP Deployment Failed

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: TiUP部署失败

| username: TiDBer_TLK8Du2x

I am using the server provided by the school and connecting to two servers through a jump server. The control machine is configured with passwordless SSH, but there are still SSH errors during the check, as shown in the picture.

How can I solve this? There is no problem when I use root on my own virtual machine.

| username: 有猫万事足 | Original post link

You set up passwordless access for the tidb user, but not for root, right?

This prompt indicates that you didn’t provide a password when logging in as root. If it doesn’t work, try adding -p to the command you originally entered and then input the password to see if it works.

| username: lemonade010 | Original post link

Manually SSH to see if it works. If not, add the -p parameter to deploy using a password.

| username: 小龙虾爱大龙虾 | Original post link

:anguished: Schools are starting to use TiDB now.

| username: jiayou64 | Original post link

Should the root user operate or the tidb user?
Both should establish mutual trust. If both are done, after the user logs in, test logging in with ssh username@ip.

| username: 像风一样的男子 | Original post link

You can go talk to the school and set up a course.

| username: 小龙虾爱大龙虾 | Original post link

I want to follow along and learn :rofl:

| username: ziptoam | Original post link

Try using a password first, without using passwordless authentication.

| username: Kongdom | Original post link

Many universities have offered courses.

| username: 我是吉米哥 | Original post link

Manually test if passwordless login is working: ssh root@ip hostname

| username: zhaokede | Original post link

Is passwordless authentication working properly, and are the users consistent?

| username: ffeenn | Original post link

Manually enter the password.

| username: Tom_wu | Original post link

Try setting up passwordless access for root as well.

| username: ziptoam | Original post link

Password-free login, enabling root login in sshd, etc., all need to be checked.

| username: zhanggame1 | Original post link

Do you have a root account? Use root to install: -user root -p

| username: Kongdom | Original post link

Refer to the documentation and follow the steps:

| username: YuchongXU | Original post link

Check the SSH configuration.