Unable to Shut Down Container in k8s

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: k8s下容器无法关闭

| username: TiDBer_GfP8VRvw

[TiDB Usage Environment] Testing
[TiDB Version] v6.5.0
[Reproduction Path] Deployment in k8s environment, container cannot be shut down
[Encountered Problem: Problem Phenomenon and Impact]
[Resource Configuration]
[Attachment: Screenshot/Log/Monitoring]

| username: xfworld | Original post link

Is there any error described in the pod’s logs?

| username: TiDBer_GfP8VRvw | Original post link

I used NFS, and it is possible that NFS went down, causing the inability to unmount.

After a long time of being unable to stop, even docker kill didn’t work, so I directly used systemctl stop docker. Then, after starting NFS and using kubectl delete pods again, it worked. Thank you very much.

| username: xfworld | Original post link

The NFS is down. Just restart the related NFS utils services, and the connection will be automatically rebuilt… :upside_down_face:

| username: TiDBer_GfP8VRvw | Original post link

Yes, I needed to evict and migrate a k8s node. All other pods were evicted, but the TiDB pod didn’t move at all. When I tried to check the information, I found it was already in a terminated state, so I couldn’t view the logs or anything. I didn’t think about the NFS issue at that time. Later, after stopping Docker, I remembered it. Thanks a lot.