How to set the status-host for TiDB when using tiup to install TiDB, listen_host has been set, but the status listening port is not bound to that address

This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 使用tiup安装TiDB如何设置tidb的status-host,已经设置listen_host,但是状态监听端口未绑定该地址

| username: TiDBer_oqrCNpbV

In the TiDB configuration file, the listen_host has already been configured:

After starting the service:

TiDB listens to the IP address specified by listen_host, but the status port is still bound to the default address and does not use listen_host. Is there any way to set this?

| username: h5n1 | Original post link

Try using the status.status_host parameter.

| username: TiDBer_oqrCNpbV | Original post link

Is it configured like this? It doesn’t seem to work.

| username: TiDBer_oqrCNpbV | Original post link

Why can the status_port of TiKV use listen_host to specify the listening port, but TiDB cannot?

| username: ShawnYan | Original post link

Refer to the official documentation: 通过 TiUP 部署 TiDB 集群的拓扑文件配置 | PingCAP 文档中心

| username: TiDBer_oqrCNpbV | Original post link

The listen_host in the official documentation is only effective for tidb, pd, and tikv. This test is valid, but prometheus, grafana, and Monitored do not support the listen_host configuration. How can I configure these to listen to the local IP address?

| username: zzzzzz | Original post link

Prometheus, Grafana, and Monitored are third-party components. Please confirm what status needs to be monitored.

You can refer to the Prometheus and Grafana official websites for details.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. No new replies are allowed.