Point Get Slow

This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: point get 慢

| username: TiDBer_Terry261

[Test Environment] TiDB
[TiDB Version] 6.6.0
[Reproduction Path] What operations were performed to encounter the issue
[Encountered Issue: Phenomenon and Impact]
Querying a table using a unique key takes about 400 milliseconds.

This table only has 276 records in total, and the execution plan

seems fine.

[Resource Configuration]

Why is the point query so slow? Can anyone help take a look?

| username: 裤衩儿飞上天 | Original post link

  1. Post the execution plan.
  2. There might be a read hotspot. If the table is not frequently updated, you can use small table caching in version 6.X.
| username: TiDBer_Terry261 | Original post link

The default value of tidb_gc_life_time is 10m, which means that data older than 10 minutes will be cleaned up. You can adjust this parameter according to your needs. For example, if you want to keep the data for 1 hour, you can set it to 1h.

| username: tidb菜鸟一只 | Original post link

Go to the SQL section on the dashboard interface and check which part is slow.