Port 9090 is occupied

This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 9090端口被占用

| username: rw12306

[TiDB Usage Environment] Production Environment / Testing / PoC
[TiDB Version]
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
The TiDB monitoring port is occupied. The database has already been installed and deployed, but the 9090 port is occupied by a system process and cannot be killed, causing the monitoring program to fail to start.
[Resource Configuration]
[Attachments: Screenshots/Logs/Monitoring]

| username: 啦啦啦啦啦 | Original post link

Try scaling down the monitoring, changing the port, and then scaling it back up to see if it works.

| username: hey-hoho | Original post link

Is it using the Kylin system? Port 9090 is occupied by a system service. Just follow the method mentioned in the first post.

| username: ShawnYan | Original post link

Big bro, you’re awesome, you recognized it at a glance.

The COCKPIT monitoring tool that comes with the Kylin server operating system uses port 9090;
[root@localhost ~]# lsof -i:9090
Stop the COCKPIT service to free up port 9090
[root@localhost ~]# systemctl stop cockpit.socket

| username: rw12306 | Original post link

It’s Kylin Linux.

| username: 大飞哥online | Original post link

Method 1: Disable the cockpit service in Kylin
Method 2: Modify the configuration file of the monitoring to change the port

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.