Set tidb_mem_quota_query to 1G but still see some queries exceeding 1G on the dashboard, what's going on?

This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 设置了tidb_mem_quota_query 为 1G 但是看dashboard 还是有一些 超过1G 的,怎么回事?

| username: TiDBer_NxOGHZx6

[TiDB Usage Environment] Production Environment / Testing / PoC
[TiDB Version]
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots / Logs / Monitoring]

| username: 连连看db | Original post link

What is your TiDB version?

| username: TiDBer_NxOGHZx6 | Original post link


| username: 连连看db | Original post link

Check if the variable tidb_mem_oom_action is set to LOG. If it is set to LOG, the SQL will still execute, but an execution log will be printed in the log file.

| username: 路在何chu | Original post link

I don’t have this parameter. Version 4.0. I set that one, but it doesn’t work.

| username: TiDBer_NxOGHZx6 | Original post link

Okay, I’ll take a look.

| username: dba远航 | Original post link

The actual memory usage can exceed the tidb_mem_quota_query setting; it is not a hard limit.

| username: 烂番薯0 | Original post link

If the statement exceeds a little, it can still run.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.